so-netブログに広告が表示されているのにAdsence管理画面でアクティブにならないときの対処法

アドセンス審査OKなのにアクティブにならない現象

私はアドセンスが無事に審査通過しコードを取得したあと、しばらくso-netのブログに表示させることができませんでした。
症状は、

A: PCでは表示されていて、アドセンス管理画面でもアクティブになっているのにスマホで表示されない

あるいは、

B: スマホで表示されているのに、アドセンス管理画面でアクティブになっていない
(当然視認されていない)

という状態。Aが解決するとB、Bが解決するとAになる、を繰り返しました。

not-active

解決方法紹介サイトで、アドセンス取得後しばらくは表示されないから待った方が良いというアドバイスを見かけたので、数日待ってみたりもしたのですが、広告稼働表示はずっと新規のままで1週間以上アクティブになりませんでした。
あれこれ試行錯誤した結果、このABどちらも解決したので、その方法を記録しておきます。

ちなみに私のブログ作成環境は、
Mac Mini/MacOSX(10.8)/ブラウザ:Chrome です。

【最初やってみた方法】
(1)so-netブログでアドセンス取得
(2)アドセンス管理画面の「広告設定」から、
 新しい広告ユニットを作成、「自動サイズ-レスポンシブ」で「保存してコードを取得」
(3)「広告ユニットを作成しました」画面に表示された広告コードをコピー
(4)設置手順の指南サイトを見ながら(3)をブログに貼る

この(4)貼り付ける手順が問題だったようです。

so-netの管理画面でコンテンツ配置の「記事」を開いて設置する方法がよく紹介されています。記事を投稿するたびに設置する手間が省けるというやつですね。でも私の場合これだとスマホでは表示されなかったので、スマホに貼るための手順も調べました。
これをやると、スマホで表示されましたが、今度はPCで表示されなかったり、またアクティブではなくなったり・・・ 格闘すること2週間。当然アナリティクスも線が微動だにせず。ブログ村のランキングは順調に上がっているのにーーー(T_T)
表示に成功してからはso-netやブログ村で見るPV数に比例するように、収益が発生するようになりました。

スポンサーリンク

「リッチテキストエディタ」ONで記事を、OFFにしてからアドセンスを

結局たどり着いた方法がこれです。

(1)〜(3)までは同じ。
(4)so-net「設定」→「リッチテキストエディタを利用する」にして、「設定を保存」
richtxt-on
(5)新規作成画面で普通に記事を書く
(または別のテキストエディタで作成したものを流し込む)
(6)記事の文字装飾や画像挿入
(7)また「設定」画面に戻り、「リッチテキストエディタを利用しない」に
変更、「設定を保存」
richtxt-off
(8)記事編集に戻り任意の場所に広告コードをペーストして保存
ad-harituke

動作の重いso-netで、設定画面と記事管理画面を行ったり来たりでちょっと面倒ですが、これでPCでもスマホでも正しく表示され、アドセンス管理画面でもアクティブになりました。
(この設置完成画面はこちら

platform来訪者の7割近くが携帯端末からのようなので、少々面倒でもやっておいた方がよいですね。

毎回投稿のたびにこの動作というのは何とかならないかとは思いますが、慣れてしまえばたいしたことはありません。

表示がうまくいかない原因が何なのか、お恥ずかしながら結局よくわかっていません。
他のブロガーさんはこんな不具合なくサクッと貼付けられているのかもしれませんが・・・
どなたか詳しい方、解説していただけると嬉しいです。
同じような症状の方のお役に立てれば幸いです。

補足

【補足1】記事公開後、文字だけの訂正なら「リッチテキストエディタを利用しない」のままでできますが、ちょっと画像や文字の装飾を変えよっかなーと一旦「リッチテキストエディタON」に変更していじるとまたアドセンス広告表示が消えたりコードがそのまま見えちゃったり・・・ ということになるのでご注意を。(普通はそんなことにはならないのかも(^_^;) あくまでも私と同じ症状の方へのご報告です)

【補足2】現在、当ブログでもアドセンス設置しておりますが、WORDPRESSでは上記のような面倒な手間は一切ありません。so-netならではの問題点なのでしょう。

スポンサーリンク

  • このエントリーをはてなブックマークに追加